Announcement

Collapse
No announcement yet.

Firmware won't update

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Firmware won't update

    Hi
    New to this forum.
    I am also new to 3D printing and have an ANET A8.
    I configured the auto levelling sensor but was having issues with the set-up.
    Someone recommended updating the firmware.
    I followed these instructions....
    https://github.com/SkyNet3D/anet-board

    Keep getting this error when running the upload.

    In file included from sketch\sketch_jan02a.ino.cpp:1:0:

    C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.21.0_x 86__mdqgnx93n4wtt\hardware\arduino\avr\cores\ardui no/Arduino.h:223:0: note: this is the location of the previous definition

    #define TIMER5C 18

    ^

    Sketch uses 510 bytes (0%) of program storage space. Maximum is 126976 bytes.
    Global variables use 9 bytes of dynamic memory.
    avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xd6
    avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x6f
    avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x80
    avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0xbf
    avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0xae
    avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0xd6
    avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x02
    avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x21
    avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0xcc
    avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0xd6
    An error occurred while uploading the sketch

    This report would have more information with
    "Show verbose output during compilation"
    option enabled in File -> Preferences.

    If anyone can tell me what I am doing wrong it would be greatly appreciated.
    Thanks in advance.

    #2
    Hi, I am having what appears to be a similar problem. I'm into my third week and am running out of ideas on how to solve it. If you find the answer please let me know. Same as if I do I will pass it on to you. Good luck we both need it.

    Comment


      #3
      I updated to the latest version of both Arduino and Marlin and still nothing. Going to try a USBAsp Bootloader. Ordered one off Amazon and it should be here by Friday. I'll let you know if it works.

      Comment


        #4
        I had a similar issue and this helped me.
        https://forum.arduino.cc/index.php?topic=589183.0

        Comment


          #5
          USBAsp Bootloader was successful! Now it looks like I need to order a new ABL sensor as the one I have is not functioning properly.

          Comment

          Working...
          X