Announcement

Collapse
No announcement yet.

Problems setting up BLTouch on Ender 3 V2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Problems setting up BLTouch on Ender 3 V2

    I am hoping I can get some help with setup of a BLTouch on a Reality Ender 3 V2 - I've tried just about everything I can think of but nothing has produced useable results so far.

    Some background: I've been using a Monoprice Maker Select v2 for several years, doing most of my printing via Octopi. Eventually my printer started acting up a bit, and a couple of months ago I decided to upgrade to an Ender 3 v2. I really liked the printer at first, and did several really nice prints right away with no issues. Shortly after that I started having trouble with prints failing to stick to the bed; I discovered that the bed had become bowed in the middle. I was able to get around this by putting some aluminum foil pieces on the center of the bed, between the bed and the tempered glass sheet, and double-checking nozzle height in the center as well as at the four corners before each print. However since I knew the v2 was BLTouch-ready, I decided to add one so that it would compensate for any bed irregularities.

    I bought a BLTouch from Amazon, and then basically followed this tutorial to the letter: https://www.youtube.com/watch?v=jO4PAWvWdH8. This suggests using the firmware from this page: https://smith3d.com/ender-3-v2-bltou...by-smith3d-com - so I downloaded the recommended version (V2.0.X.14, slow probe 5x5) and installed it on the printer. I had trouble setting up the z-offset; I followed the instructions exactly, but after getting the offset perfect according to the instructions, I would then go to print and the nozzle would be way too high. In the end I used trial and error, doing a level-test print that covers most of the bed. I was able to get the z-offset to what seemed to be an acceptable setting, but no matter what I set it to, when I try to print the nozzle is always much closer to the bed at the front than at the back. So at the best possible z-offset setting, when I print the first layer, the filament is hardly being 'squished' at the back at all and is just barely adhering to the bed, so the nozzle is too high - and at the front, the nozzle is pressed against the bed so that no filament emerges at all.

    Some notes on observations, settings and things I've tried:
    -- As far as I can tell, this is a genuine BLTouch from Antclabs; it has the QRcode and the correct markings for a genuine model, and it was advertised as such on Amazon. The version is 3.1.
    -- The z-offset that I enter is being stored correctly by the printer.
    -- I have added the G29 to my Cura profile, and double-checked the gcode to make sure it is being included - so a new mesh is being created at the beginning of each print.
    -- The BLTouch appears to respond correctly when the probe touches the bed, and the printer is responding when this happens (i.e. the print head is being raised when the BLTouch is triggered), so everything seems to be working as it should.
    -- However, every few times I turn on the printer, the BLTouch fails self-test (the probe does not extend or retract) and the red LED starts flashing until I restart the printer again.
    -- The BLTouch is mounted correctly, it is not loose or angled in any unusual way.
    -- All the wheels on the Ender 3 V2 are tightened so there is no play in the bed or anywhere else in the printer.
    -- I am using a 1mm spacer instead of using the springs that came with the BLTouch, so there is no play in the height of the BLTouch.
    -- The best z-offset I have been able to find is -0.7, but as stated above, with this setting the nozzle is too high at the back of the bed and too low at the front.

    Any suggestions? Do I have a bad BLTouch? Or should I be using different firmware? All suggestions are very much appreciated - this is getting very frustrating ...

Working...
X