Announcement

Collapse
No announcement yet.

Ender 5 Pro - Can't Connect to PC for BLTouch Firmware Update

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Ender 5 Pro - Can't Connect to PC for BLTouch Firmware Update

    Hello all, this is my first post. I recently picked up a slightly upgraded Ender 5 Pro from amazon as my first printer. I have it set up and after some belt tweaking and bearing adjustment it is printing very nicely. I want to ad the BLTouch, and have the Creality kit labeled for V1 Mainboard. I have several questions, and I can't find any specific solutions to the Pro version, which I think has built in bootloader.

    First, the kit comes with a USB ISP cable and interface, but I'm not sure I actually need to use that. I'm under the impression I should be able to update the firmware directly from my computer to the mini usb port on the front of the machine, similar to the CR10 V2.

    I've installed the Creality Slicer from the sd card, and downloaded the Creality BLTouch driver hex file from their website. I checked that my z axis screw is the 4mm travel type as well, since there are files specific to 4mm and 8mm models.

    Here are the steps I followed:
    1. connect usb from front of printer to PC (not the usb ISP cable).
    2. Check the comm ports to see what pops up (com 3 ch340 or something similar)
    3. Open Creality Slicer and set machine settings to com port 3 and baud rate to 115200 as instructed by Creality.
    4. Navigate to the upload firmware section and select the downloaded hex file.
    5. When it tries to connect to the printer I see the screen refresh on the printer, but the connection quickly fails after that. I get the connection error message in the slicer program that asks me to confirm my printer is connected.
    It almost seems like the connection attempt is timing out too quickly before the printer can respond. I scoured the web looking for solutions and downloaded the older 15.04.6 version of Cura and had the same results. I tried the latest Cura as well, with no change. I checked the driver setting in the com port. The default baud rate is 9600 there, and I tried matching that to the printer baud rate and still same error. I tried all baud rate combinations in the port settings and in the slicer machine settings with no change. I reinstalled the FTDI drivers too.

    I tried disconnecting the USB cable and instead used the USB ISP cable connected to the main board. I get the blue light and the panel comes to life. But when I plug it in to my PC it registers as a USBHID device, so it doesn't show in the com ports section. The instruction video shows a program called progisp.exe being used with the usb ISP cable, but this is not included in the Ender 5 download material. I'm guessing this is a bootloader program, and it's not included because it isn't needed for this printer version?

    I just can't seem to get the PC and printer to talk to each other for the firmware handshake. Any help is greatly appreciated, as I've pretty much exhausted my own knowledge on these settings.

    I'll take a workaround too but I have no experience with things like Arduino, no programming experience, and I had to search the web to find out what a bootloader is


    Cheers!

    MB747
Working...
X