Announcement

Collapse
No announcement yet.

Anet A8 burns power linesin the wall after MOSFET?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Anet A8 burns power linesin the wall after MOSFET?

    I am puzzled after I upgraded my A8 with MOSFET. Before that it worked properly, I began test printing for one and a half hour. It didn't print properly, but that's another story (the filament would not stick to the bed and it curled up on the nozzle outside). After the upgrade the electric lines in the wall got damaged.

    I took these steps upgrading the MOSFET and power switch:
    - I wired the socket & switch using wires from the original A8 power cord (picture included)
    - I tested the socket with 3 light bulbs, 180W in total, for an hour, it worked perfectly.
    - I installed the switch to the PCU L to L, N to N, ground to ground. (I followed this guy's tutorial, but not in all parts https://www.youtube.com/watch?v=Pauq99Wwhp8)
    - I used wires from the printers power cord from the PCU to the MOSFET just like in the tutorial
    - I removed the hot bed wires from the board and connected them to the MOSFET
    - I used the thin, unreliable looking wires the MOSFET came with to connect the MOSFET to the board (if I understand right, those cables should work fine)
    This is the Wiring diagram I followed beside the tutorial: https://3dprint.wiki/_detail/reprap/...heatbed_mosfet with the difference that the mainboard is still powered directly from the PCU, and is not wired to the MOSFET + and -.

    I connected the printer to the socket on the wall, and switched it on... within 5 seconds I heard a buzzing noise from the socket and the light on my ceiling started to blink. I shut the printer off immediately. Strangely, the printer did work while it was switched on, and even my PC worked fine, it being plugged in the same socket on the wall. But after about an hour I could smell fishy burnt smell and by further examination I found the burnt wire inside the socket. I can't find anything wrong on the upgrade. As far as I know, the printer uses only 50 to 150W. The wires should be able to handle 300W or more.

    Does this printer take a heavy load on the electrical system? What do you think went wrong?

    (Edit: progress was made, I found the wire that melted)
    Last edited by forzal; 04-23-2019, 04:56 PM.

    #2
    I would not be so quick to blame the printer, a loose connection in the socket or to the wires connecting the socket could cause that problem. If it was caused by too much draw, the entire wire would be melted. Replace the socket and it will probably be fine. Heat is usually caused by poor connections. I assume that the socket is correctly fused.

    Comment


      #3
      Thank you for the reply. You are right, only the end of the wires were burnt, so it could be loose connection. I switched on the printer several times, and it seems to work fine. I will try to print again, and see if the wires can handle it.

      Comment

      Sign Up

      Collapse

      To post a reply to this thread you must be a member. Registration is fast, simple and absolutely free. Please join our community today!
      Working...
      X