Announcement

Collapse
No announcement yet.

Switch to RAMPS, maybe bad driver?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Switch to RAMPS, maybe bad driver?

    Ok, first of all, I'd like to say hello! Thanks for having me and to whomever takes the time to read this. Second, I'm gonna' try and keep this ordered sensibly, but it's kinda' convoluted, I think. So...

    I've been using an Anet a8 for, well, 3 spools of filament now. I've learned a good bit in this time, and recently decided to move to RAMPS. So I got what seems to be thd basic RAMPS 1.4 kit, with a Mega and the Polulous (sp?), LCD and whatnot. Found out the joys of extending my cable and switching plug types, lots of shrink wrap.

    Anyhow, the drivers (A4988, I believe, has the trimpots on the right) were all installed the same, unadjusted. When I first tried the setup, the y-axis made more than its fair share of noise. The x-axis was totally quite. First, I checked the wiring, then I decided to swap the motors (x and y, that is). The y motor was silent on the x line (and driver), just like the other (and many hours in the original setup).

    I noticed the y motor was hot to the touch after maybe 750mm of movement, far moreso than the x. So I tried turning down the pot on the y driver. It just seemed to make it stall (only in reverse, oddly). So I turned it up one quarter turn at a time, until the motor ran again. At this point, after enough movements on the y-axis, the motor started intermittently shivering or audibly quaking in between movements. The rotor wouldn't move, but the whole motor definitely shook (and clicked).

    Last, I decided to move the (faulty?) driver over to the x driver's socket. It immediately produced the same irregularities in both motors (actually not sure which is which now, lol). When I removed the y driver from the x socket (after, like, 150mm of movement), the driver was very hot. As in, nearly burned me on contact. The x driver (after 200+mm) was still cool to the touch.

    I have come to a few conclusions from all this. 1: the fault follows the driver. 2: it happens regardless of the trimpot setting. 3: the driver should be turning off if it hits those temperatures. 4: this thermal failsafe could be causing the motor quaking.

    If it's not the driver, I don't know what to make of the situation. For the info', it's Marlin firmware with Repetier as the host, the Arduino Mega's made in Italy, and the RAMPS is big-tree-tech (sorta' odd), I'm running on and Alliead Electronics ATX (8 and 13 amps on the 12v rails), controller has a box fan. Sorry for the long post, I figure thoroughness would be helpful here. Any help would be very appreciated.

    #2
    well it seems you know what your talking about but did you adjust pots by just turning or did you set it by voltage. I will assume all drivers are facing right and that when you cut and added new connectors all wires were in same order. Why did you change to ramps if an old board failed ? why ?. Have you set the jumpers below the drivers for 1/16 or 1/32. As far as drivers overheating they will shut down until cool again. and will get hot if current(pot) setting is to high. One thing to try is run the drivers with 1/16 if they r on 1/32 now. The next is marlin settings they need to match that microstep used and steps/mm set according depending if motors are 1.8 deg or 0.9. The motors will run noisy eratic and hot if drivers are bad or out of adjustment. So a hot driver or hot motor indicates current needs to be precisely adjusted.

    Comment


      #3
      Thank you for the detailed reply. I adjusted the pot in quarter turns (shutdown each time), and retried the motor (until it stopped turning). Voltmeter on the line would definitely be more accurate I suppose. All the wires are definitely in the same order. Checked repeatedly, lol. Seemed strange that it would get hot so close to cutting out. Unless it was just shuting down from heat throughout the test.

      All of them are set to 1/16, believe (all three pins). That is the only one that makes noise. Motors are all identical, Anet stock (42sdhc, I think), 1.8 deg, same settings. If I move the driver to a new spot, that motor does the same thing as the y. And they are set to the same microstep settings in the configuration. I tried lowering acceleration and jerk as well, but that didn't stop it. Putting the x axis' driver in did, though.

      I feel like the driver should be shutting off from the heat, btw. But it doesn't seem to. I turned the pot back up, and the motor turned again. So I don't think the driver had disabled itself. But it did try to burn me; I know they run hot, but I can touch the others after just a few minutes. This one worries me.

      Maybe I pet my cat too much and touched it? Lol. Btw, my old controller's fine. The hotbed died (melted, of course), but I just split the conduits and used the unused board connectors... Side note, why in the Hell didn't they use those? :/ This conversion is for dual extrusion (have the fan extension coming, they don't really mention that). And if you're patient with your nozzel heating times, and have a fan on the transistors, the board doesn't even melt! *kocks on wood*

      Comment


        #4
        Eh, mosfets are coming in the mail... And I use blade fuses. So not entirely relying on Chinese engineering and superstition here.

        Comment


          #5
          those are the connectors used on arduino shields not the best. I took those yellow resettable fuses off my ramps and used inline glass types those fuses on ramps r junk. I wouldn't really trust the Mosfets on the ramps so external is best get the high current off the board the green connectors r poor also. I am considering a duet or making my own to get 32 bit. I use a meter connected to a metal jewelry screwdriver so it reads as I turn it and I went with drv8825 stepper drivers pot is at opposite side. a lot of people r using the tmc type but they use spi control that the lcd uses so modification needed they are self adjusting current. It is possible that stepper is bad. But I know if the pot is off those drivers could boil water. there is a fine line where the motor stalls with a wine and another where is stutters like grinding gears

          Comment


            #6
            I was told it's only 1/16 and I believe in it because It's possible and makes noise. moreover, the engines are the same, but the stock Anet (42sdhc), 1.8 deg, there are the same settings. And only then does this engine do the same thing as y top casinos. It is impossible not to say that they are installed to the same microstep settings in the configuration. my friend tried to reduce the acceleration and jerk, but it did not stop him. and only after the driver is installed, the x-axis helped
            Last edited by Salena; 07-11-2019, 07:20 AM.

            Comment


              #7
              So... I quit getting on here 'cause my post gets flagged as spam for 1 effin' reference to a product stats, and no one (moderator) ever looked at my message. Now this blatantly half-baked spambot gets on and throws down a post about casinos without a backward glance? To Hell with you 3dprintingforum.org! Moderate someone else... Oh, and btw, "spambot" is all I have to say to point out a spambot. Get your crap together.

              Comment

              Sign Up

              Collapse

              To post a reply to this thread you must be a member. Registration is fast, simple and absolutely free. Please join our community today!
              Working...
              X