No announcement yet.

control board ignores x axis limit switch

  • Filter
  • Time
  • Show
Clear All
new posts

    control board ignores x axis limit switch

    This one has me stumped. Can't even figure out how to troubleshoot this.

    Machine is a zonestar - Prusa clone. Machine was working fine, but the print lost adherence to the board so I stopped the print using the 'stop print' option under the SD card menu.

    When I restarted the machine, it started normally, with a normal display. The bed and head temperatures came up normally. But when the machine zeroed all its axes, it failed to stop on the x axis, continuing to grind away at the belt until I pulled the plug.

    I confirmed the behavior - it'll do it every time. I reset the board using the on-board reset switch, but that had no effect. I checked the switch with an ohm meter, and it's working correctly. I checked the carriage travel, and the switch does indeed trigger when the carriage reaches the stop. I homed the y and z axes through software, and they both homed normally and stopped. But when I tried to home the x axis through software, it ignored the limit switch and continued to grind away until I pulled the plug.

    Basically, the board isn't paying attention to the X axis limit switch.

    Anybody got any ideas?

    Did you check the switch at the control board (all the wires to the switch). I had a bad crimp on one that took me a couple of trys to find. If the wires/switch are good, then it has to be something with the controller. What type of control board does it use?


      I am speculating that there are similarities between all printers that transcend various companies.

      With that being said.

      Whenever that happens with my BFB Touch, I have found it necessary to reload the Firmware.

      If you follow the directions to the letter you may find a function like I did that allows you to save the settings
      that are stored in the memory to be reinstalled after you reinstall the Firmware.

      You are not going to ruin the board if you follow the procedure as described.

      And you cant go wrong by refreshing the Firmware.

      If you go to the machines site, generically seeking, don't be surprised to
      find that there may be a new version of firmware available for your model.

      If the Firmware wont do it there may be a loose connection.

      It looks like you already covered that though.

      Good luck, I hope this helps


        Or a bad hall effect sensor.


          Hi, everyone - and thanks for all the input.

          I checked the limit switch by detaching the plug where it attached to the board, and checking resistance at the plug. This proved that the system was working up to the plug. It's possible that the receiving socket may have a problem, but I should be able to check for that from the other side of the board. I'll do that.

          The controller board is a Melzi 2.0 board made for Zonestar (custom color board and logo). Here's a link to the board on their website:

          (These damned links don't seem to work properly for me. Just go to the aliexpress website and search for zonestar control board.) This is a Melzi 2.0, and they seem common enough in the $40 or so price range. Rambo boards are up around $100. I'm curious as to whether the increase in price is worth it. What does a Rambo do that a Melzi 2 does not?

          I did try flashing the eprom. At least, I flashed something, and I expect it was the eprom on the printer. I ran a supplied software routine on my win 7 machine, which then stated that it was erasing chip, reading input file, writing flash... etc. It took several seconds to complete and would only work when the printer was connected via usb to the computer, so I expect I did flash the eprom on the 3d printer.

          As I think of it, I flashed from the file supplied with the printer, which would probably contain the same flash image as the one on the eprom. Yes, it would make sense to go and check for more recent eprom updates on the zonestar website. Don't think it will fix this problem, but hell. It's certainly worth trying.

          I have a hall sensor on the Z axis (although I haven't connected it; I'm still using the microswitch)and the X and Y are conventional mechanical microswitches.

          Thanks all. I'll go check throughput connectivity on the X axis socket.



            Just a quick update - I did in fact have good contact to the plug, so I contacted the manufacturer, zonestar. The machine has, at least in theory, a 6 month warranty. In my email I detailed the information outlined above, stated that I felt it might be the board, and requested help.

            The rep got back to me and asked me to send him pictures of the front and back of the board.

            I have no clue in the universe what that might be about. I've had a really hectic couple of days, so I haven't gotten around to it yet. But it seems an odd first step in troubleshooting.



              They are probably wanting to verify the model of the board, maybe even a rev level. I bought a battery charger once that was DOA out of the box. The vendor requested I send him a picture of it. I did, and they sent me a new one. I still haven't figured out what info they could obtain from a picture of a battery charger that was as dead as a stick.


                They do it for a couple of reasons. First to verify the make and model of the board. They probably cross check it with your order. Second, they make sure you still have the unit. Hopefully, they will follow through quickly.


                  There is an M code I think that will return the status of the limit switches. If you run the code with the switch open and closed, that will tell you if the firmware is reading its state properly. That's where I would start.
                  free ringtones download and or popular ringtones
                  Last edited by Luxion; 12-13-2016, 07:10 AM.


                    M119 reports the status of the switches


                    Register or Login